New inReach devices unable to activate

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 15:21 EDT

Investigating

New and factory-reset inReach devices may hang on "Activating". Existing active devices are not affected.
Posted Apr 27, 2026 - 15:07 EDT
This incident affected: Satellite Activation and Subscription Billing.