Explore map and MapShare data updates may be delayed for some customers
Incident Report for Garmin Services
Resolved
This incident has been resolved.
Posted Oct 11, 2024 - 16:35 EDT
Identified
The issue has been identified and a fix has been implemented for new track points. A fix for displaying track points sent between 3pm Eastern on 10/8 and 12pm Eastern on 10/9 is in progress.
Posted Oct 10, 2024 - 14:00 EDT
Investigating
Delays in track points showing up in Explore, including on the Map tab as well as MapShare, are possible for some North American customers. We are currently investigating the issue.
Posted Oct 09, 2024 - 13:04 EDT
This incident affected: Garmin Explore Website and MapShare.