Explore application unable to stream satellite imagery

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 13:56 EDT

Identified

The issue has been identified.
Posted Jul 02, 2025 - 13:32 EDT
This incident affected: Garmin Explore Mobile App.