Garmin Subscription Services Activations

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 04:18 EDT

Investigating

Some customers may be experiencing issues activating subscriptions. We are investigating the issue.
Posted Oct 23, 2025 - 03:53 EDT
This incident affected: Satellite Activation and Subscription Billing and LTE Activation and Subscription Billing.