inReach Messaging Delays for Some Customers

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted May 27, 2026 - 17:53 EDT

Investigating

Some inReach customers may be experiencing delays with messaging. We are actively investigating the issue.
Posted May 27, 2026 - 17:12 EDT
This incident affected: inReach Messaging.