Garmin Subscription Services Activations

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 06:40 EDT

Investigating

Some customers may be experiencing issues activating subscriptions. We are investigating the issue.
Posted Oct 20, 2025 - 05:55 EDT
This incident affected: LTE Activation and Subscription Billing.