Data syncing may be degraded for some customers in Europe, the Middle East, and Africa

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted May 25, 2026 - 11:36 EDT

Monitoring

We are continuing to monitor sync performance in the Europe, Middle East, and Africa region, but have seen improved performance since approximately 11:00 EST (15:00 UTC).
Posted May 25, 2026 - 11:26 EDT

Update

We are continuing to investigate this issue.
Posted May 25, 2026 - 10:48 EDT

Investigating

The Garmin Messenger Mobile App, Earthmate Mobile App, and Explore Mobile App have been experiencing issues with sync in the Europe, Middle East, and Africa region. We are currently investigating this issue.
Posted May 25, 2026 - 10:48 EDT
This incident affected: Garmin Explore Mobile App, Garmin Earthmate Mobile App, and Garmin Messenger Mobile App.