Some Satellite Messages Delayed in Americas

Incident Report for Garmin Services

Resolved

All delayed messages have been delivered now and messages flowing through system without any issues now.
Posted Feb 03, 2026 - 06:43 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 03, 2026 - 06:27 EST

Identified

Issue is identified and we are working on delivering the queued messages.
Posted Feb 03, 2026 - 06:25 EST
This incident affected: inReach Messaging, Garmin Earthmate Mobile App, and Garmin Messenger Mobile App.