Explore map and MapShare data updates may be delayed for some customers

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted May 15, 2025 - 09:48 EDT

Update

We are continuing to investigate this issue.
Posted May 15, 2025 - 08:58 EDT

Investigating

Some European customers using older inReach devices may experience a delay on data appearing on Explore map and MapShare. Activations of older devices could also be delayed.

Person-to-person inReach messaging is not affected, although location links may not be immediately available.
Posted May 15, 2025 - 05:35 EDT
This incident affected: Garmin Explore Website and MapShare.