Iridium Device Activations and Plan Changes Delayed

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 22:06 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 24, 2025 - 21:03 EDT

Update

We are continuing to investigate this issue.
Posted Jul 24, 2025 - 17:33 EDT

Investigating

Iridium device activations, plan changes, and cancellations are currently delayed. Any pending changes will complete when service is restored. We recommend waiting to activate, deactivate, or change plans on your device until this incident is resolved.
Posted Jul 24, 2025 - 14:20 EDT
This incident affected: Iridium Activation and Subscription Billing.