Degraded Explore performance for Europe

Incident Report for Garmin Services

Resolved

Service for the Explore website and MapShare in Europe is restored and response times are back to normal
Posted Jun 06, 2025 - 16:31 EDT

Investigating

Some European customers may experience issues accessing the Explore website, including managing data, deleting data, and viewing messages. These issues do not impact device messaging or SOS functionality.
Posted Jun 06, 2025 - 14:43 EDT
This incident affected: Garmin Explore Website and MapShare.