Messages from inReach devices to SMS or email may be delayed
Incident Report for Garmin Services
Resolved
This incident has been resolved.
Posted Aug 28, 2024 - 20:57 EDT
Investigating
We are currently investigating this issue.
Posted Aug 28, 2024 - 20:24 EDT
This incident affected: SMS/Text Communication and Email Communication.