Garmin Explore Website is unresponsive for parts of the US

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Jun 01, 2025 - 14:34 EDT

Investigating

Garmin Explore Website is unresponsive for parts of the US. This will also affect inReach subscription activations in parts of the US.
Posted Jun 01, 2025 - 13:41 EDT
This incident affected: Iridium Activation and Subscription Billing and Garmin Explore Website and MapShare.