inReach customers may experience issues sending messages to US/Canada-based phone numbers on T-Mobile

Incident Report for Garmin Services

Update

We are continuing to investigate this issue.
Posted Mar 06, 2026 - 05:45 EST

Investigating

We are currently investigating this issue.
Posted Mar 05, 2026 - 18:48 EST
This incident affects: inReach Messaging and Garmin Messenger Mobile App.