Garmin Explore website inaccessible for some customers

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 14:32 EDT

Investigating

Some customers may experience issues accessing the Explore website. These issues do not impact device messaging or SOS functionality.
Posted Aug 13, 2026 - 13:40 EDT
This incident affected: Garmin Explore Website and MapShare.