Explore Website, Degraded Performance

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 15:02 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 14, 2025 - 13:19 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2025 - 13:19 EDT

Identified

Some US customers may experience issues accessing the Explore website, including managing data, deleting data, and viewing messages. These issues do not impact device messaging or SOS functionality.
Posted Jul 14, 2025 - 13:07 EDT
This incident affected: Garmin Explore Website and MapShare.