Reduced Performance for sync in Europe region

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted May 19, 2026 - 12:18 EDT

Investigating

Start Time: 7:00 AM Eastern

Impact: Some customers in the Europe region will experience timeouts when performing syncs and other actions in Explore, Messenger, Earthmate, Alpha, Tread, and other applications
Posted May 19, 2026 - 11:45 EDT
This incident affected: Garmin Explore Mobile App, Garmin Earthmate Mobile App, Garmin Messenger Mobile App, Garmin Alpha Mobile App, and Garmin Explore Website and MapShare.