Explore map and MapShare data updates may be delayed for some European customers

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Jun 08, 2025 - 13:25 EDT

Investigating

Delays in track points and messages showing up in Explore, including on the Map tab as well as MapShare, are possible for some European customers. We are currently investigating the issue.

Person-to-person inReach messaging is not affected, although location links may not be immediately available.
Posted Jun 08, 2025 - 12:40 EDT
This incident affected: Garmin Explore Website and MapShare.