Garmin Subscription Services impacted

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Apr 05, 2026 - 14:44 EDT

Investigating

Garmin subscription services are currently experiencing issues. Subscription management features, including activations, plan changes, and cancellations, may be impacted.
Posted Apr 05, 2026 - 12:48 EDT
This incident affected: Satellite Activation and Subscription Billing and LTE Activation and Subscription Billing.