Degraded Sync Performance

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 06:51 EDT

Update

We are continuing to investigate this issue.
Posted Jun 01, 2026 - 06:49 EDT

Update

We are continuing to investigate this issue.
Posted Jun 01, 2026 - 06:49 EDT

Investigating

Some customers are experiencing degraded performance affecting syncing in Explore, Messenger, Earthmate, Alpha, Tread, and other applications.
Posted Jun 01, 2026 - 05:17 EDT
This incident affected: Garmin Explore Mobile App, Garmin Earthmate Mobile App, Garmin Messenger Mobile App, Garmin Alpha Mobile App, and Garmin Explore Website and MapShare.