Partial Explore outage for US
Incident Report for Garmin Services
Resolved
This incident has been resolved.
Posted Oct 22, 2024 - 15:21 EDT
Update
Explore site is restored
Posted Oct 22, 2024 - 15:20 EDT
Investigating
Some US customers may experience issues accessing the Explore website, including managing data, deleting data, and viewing messages. These issues do not impact device messaging or SOS functionality.
Posted Oct 22, 2024 - 13:51 EDT
This incident affected: Garmin Explore Website and MapShare.