Garmin Subscription Services Management

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted May 21, 2026 - 17:16 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 21, 2026 - 17:06 EDT

Investigating

We are currently investigating an issue which may cause delays in being able to manage your subscription plan.
Posted May 21, 2026 - 16:45 EDT
This incident affected: Satellite Activation and Subscription Billing and LTE Activation and Subscription Billing.