Explore map and MapShare data updates may be delayed for some customers
Incident Report for Garmin Services
Resolved
This incident has been resolved.
Posted Oct 09, 2024 - 00:54 EDT
Update
Delays in track points and messages showing up in Explore, including on the Map tab as well as MapShare, are possible for some North American customers. These pages may also be slow to load. We are currently investigating the issue.

Person-to-person inReach messaging is not affected, although location links may not be immediately available.
Posted Oct 08, 2024 - 17:33 EDT
Investigating
We are currently investigating this issue.
Posted Oct 08, 2024 - 11:27 EDT
This incident affected: Garmin Explore Website and MapShare.