inReach Messaging Delays for Some Customers

Incident Report for Garmin Services

Resolved

This incident has been resolved
Posted May 29, 2026 - 03:49 EDT

Investigating

We are currently investigating an issue impacting messaging for some inReach customers.
Posted May 29, 2026 - 02:04 EDT
This incident affected: inReach Messaging.