SMS Messages Delayed for Some Customers

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 20:15 EDT

Investigating

We are currently investigating an issue affecting SMS messaging for customers in certain regions.
Posted Mar 27, 2026 - 19:44 EDT
This incident affected: inReach Messaging.