Data syncing may be delayed for some customers in the Americas

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Feb 02, 2026 - 16:52 EST

Investigating

The inReach Desktop App, Earthmate Mobile App and Explore Mobile App have been experiencing issues with sync.
Posted Feb 02, 2026 - 16:04 EST
This incident affected: Garmin Explore Mobile App and Garmin Earthmate Mobile App.