Iridium device activations, plan changes, cancellations delayed or blocked

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 18:08 EDT

Investigating

Iridium device activations, plan changes, cancellations are impacted due to issues at our service provider. We recommend holding off on activating or making changes for these devices until this is cleared up.
Posted Jun 09, 2025 - 16:08 EDT
This incident affected: Iridium Activation and Subscription Billing.