inReach activations may be delayed for some customers

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 18:53 EDT

Investigating

We are currently investigating this issue.
Posted Apr 28, 2026 - 18:27 EDT
This incident affected: Satellite Activation and Subscription Billing and LTE Activation and Subscription Billing.